Skip to main content

Open Editor option is not visible for me in the Living Doc view in Azure Devops

Comments

10 comments

  • Viktor Nemes

    The "open in editor" button in LivingDoc only supports Azure Repos Git and TFVS, so if your project uses a git repository hosted somewhere else (outside of Azure Devops) the button is not visible. If your project uses Azure Repos please open a support ticket here: support.specflow.org/hc/en-us/requests/new 

    0
  • Dumisani Zwelithini Sebatha

    I have been watching this post since it was opened. We are experiencing the same issue on an Azure Repos Git project. At one point I thought the "Open In Editor" feature was still under development based on the SpecFlow road map here, but seems from this post this is actually live. B Ashwini Kumari did you manage to resolve this?

    1
  • Nicolas Bailly

    Hello,

    I have the same issue.

    I use Azure Repos Git for my projects and I created a pipeline with a specflow task with "Feature folder" as described in the documentation.

    B Ashwini Kumari or Dumisani Zwelithini Sebatha , any update about a resolution?

    0
  • Heinsalu, Riine

    Hi, 

    I am having the same issue as well.
    I'm using Azure Repos Git to host the project and created a pipeline with the SpecFlow+ task with the generator source being the feature folder. I can see the test results successfully from the SpecFlow+ LivingDocs tab in ADO but the "Open Editor" button is missing. 

    Could you please provide a solution to this? 

    Kind regards,
    Riine

    0
  • Edgar Garzon

    Hi,

    I have the same issue using Azure DevOps git. I can see the living Doc but the button is not displayed.

    Any updates?

    0
  • Johan Bengtson

    Same issue here using Azure Repos Git.

    0
  • Dumisani Sebatha

    In our case turned out this was due to the fact that the pipeline(yaml) was checking out the repository (and others) into a subdirectory of the build working directory. The paths for the doc task settings were prefixed with that subdirectory name. When we changed the pipeline to checkout the repo the normal way the button just came up.

    1
  • Eric Carlson

    Having the same issue here. Azure Repos Git, Feature folder selected. No subdirectories or anything.

    0
  • Gilles Lautrou

    Any news? Same issue.

    Dumisani Sebatha Can you please explain what you changed in the pipeline?

    0
  • Daniel Nunes da Fonte

    Someone got fixed it?

    0

Please sign in to leave a comment.

Powered by Zendesk