Skip to main content

Generate Living Docs fails

Answered

Comments

6 comments

  • Jordan Western

    Hi Brett Roberts,

    I have created a new project with the package versions you specified and I am unable to replicate this issue.

    • Have you tried updating SpecFlow.Plus.LivingDocPlugin to the latest version? (3.9.50)
    • Which .net version are you using?
    • Is the dll appearing in the build output?
    • have you simply tried a clean and rebuild?
    • Have you made any project changes since your last successful attempt at generating the doc?

    Thanks, and I hope we can find a solution soon.

    0
  • Brett Roberts

    Hi, thanks for replying.

    To answer your questions

    1) Ive updated SpecFlow.Plus.LivingDocPlugin to 3.9.50 - no change, same error

    2) .Net 4.8

    3) By DLL, I assume you mean MyTests.dll (in my example command above) - Yes

    4) Yes, naturally

    5) Literally hundreds, this is a WIP project

     

    0
  • Brett Roberts

    I have an update on this.

    Uninstalled SpecFlow.Plus.LivingDocPlugin via Visual Studio
    Uninstalled SpecFlow.Plus.LivingDoc.CLI from command line

    ReInstalled SpecFlow.Plus.LivingDocPlugin via Visual Studio
    ReInstalled SpecFlow.Plus.LivingDoc.CLI from command line
    This fails with a 401 error, the specifi error is below:

    dotnet tool install --global SpecFlow.Plus.LivingDoc.CLI
    C:\Program Files\dotnet\sdk\5.0.400\NuGet.targets(131,5): error : Unable to load the service index for source https://nextgencps.pkgs.visualstudio.com/_packaging/CentralizedControlFeed/nuget/v3/index.json. [C:\Users\my.name\AppData\Local\Temp\imeof4re.xch\restore.csproj]
    C:\Program Files\dotnet\sdk\5.0.400\NuGet.targets(131,5): error : Response status code does not indicate success: 401 (Unauthorized). [C:\Users\my.name\AppData\Local\Temp\imeof4re.xch\restore.csproj]

    0
  • Jordan Western

    Hi Brett Roberts,

    Figuring out these assembly loading issues are very tricky without me having the access to your repo; I would try and create a new local project with basic set up and see if you can compare the differences to find the issue.
     
     
    Regarding your latest reply, the source you are trying to reach, https://nextgencps.pkgs.visualstudio.com/_packaging/CentralizedControlFeed/nuget/v3/index.jsonlooks like it could  be proxy related? Maybe you need to add some proxy credentials.
    0
  • Brett Roberts

    Thanks for your reply.

    Your reply gave me a few clues. Specifically the URL that included CentralizedControlFeed which sounded a bit like a project that I used to work on over a year ago which is now no longer exists (that might be the reason for the 401 error). So, in Tools > Options > NuGetPackageManager > Package Sources I disabled that source and tried again.

    Success: SpecFlow.Plus.LivingDocPlugin.CLI installed from the cmd line, successfully and generating living docs now works without throwing an error.

    What is odd is how this ever worked before. But the main thing is, its working now. Thanks for your helpful pointers.

    0
  • Jordan Western

    Hi Brett Roberts

    Glad you got this working!

    These issues can be a pain to diagnose...

    Good luck with the project and do let us know if you need any support.

    Thanks, Jordan.

     

    0

Please sign in to leave a comment.

Powered by Zendesk