Skip to main content

My report is displayed as Unnamed_timestamp.html

Comments

5 comments

  • Jordan Western

    Hi yashwanth gilly,

    Can you share the details of your project setup, what are you using to generate the report, assuming you are using the SpecFlowPlus Runner?

    Did you have a chance to look through the docs here?

    0
  • yashwanth gilly

    Hi Jordan Western,

    I took a look on the docs and thats how i created the project entirely. The report specFlow creates for every execution with the log is displayed as UNNAMED PROJECT. I tried adding the .rsProfile file to my project by creating new .rsProfile still it was not success. Also, The failed scenario is executing 3 time even though i provided stopAfterFailures = "1". Please find the project structure below with necessary screenshots for better understanding.

    Thanks in Advance!

     

     

     

     

     

     

    0
  • Jordan Western

    Hi yashwanth gilly,

    please see here, if you don't use the default naming (Default.srprofile), then your file won't be picked up by default and you need to specify the .srprofile you wish to use. I think in your case you have called it something else, and is why they are probably not being picked up (this is the solution to both your issues) -

    Using Profiles

    The name of the profile file used by your project is defined using the <Profile> tag in your .runsettings file. By default, SpecFlow+ Runner expects a file called Default.srprofile.

    Note: If you use a .runsettings file to specify your profile and are executing tests in Visual Studio, make sure you have set the settings file correctly in Visual Studio. Select Test ]( Select Settings File from the menu in Visual Studio and select your .runsettings file to do so. If your .runsettings file is not referenced correctly, your tests will run using Default.srprofile, and the results may not be the ones you expect.

    If you need to regularly switch between profiles from the command line, you can do so by adding a .runsettings file for each profile, and specifying the profile as a parameter from the command line.

    0
  • yashwanth gilly

    Hi Jordan Western,

    I just tried adding the .runsettngs file and added the .rsProfile in <Profile> as mentioned. I also added the runsettings file in the Configure Run settings from Test. 

    Please find the screenshot below,

    The newly created .srProfile file is added in .runsettings file.

    After i build the solution and try running the test. The scenarios already listed are not displayed now.

    Please refer below. I believe it is not picking the .runsettings correctly. Can you please help on this. Thanks!

     

    0
  • Jordan Western

    Did you try specifying the run settings file from the test menu option inside visual studio?

    0

Please sign in to leave a comment.

Powered by Zendesk