Skip to main content

specflow test script displays error in VS2019

Comments

6 comments

  • Jordan Western

    Hi vadivel.sekar81,

    Have you tried removing <UnitTestProvider> from your project file?

    0
  • vadivel.sekar81

    Hi Jordan,

    I have keyed-in the below details

    <specFlow>
          <unitTestProvider name="MsTest" />
    </specFlow>

    0
  • vadivel.sekar81

    Hi Jordan,

    After removing the <unitTestProvider name="MsTest" />, the build generation is passed but the Scenarios are not listed in the MSTest-TestExplorer

     

    0
  • vadivel.sekar81

    Hi,

    1. When the Project is created using the "SpecFlow project" as template, the version is V 3.9.8 where there are no issues.
    2. When the Project is created using the "MSTest project" as template and the Specflow is added/installed on top of it, the version is V 3.9.22.
       Here the GHerkin and Cucumber versions are creating the issue as per my analysis.
     
    If a project is created using the MSTest template and if the SpecFlow version is updated to the V 3.9.22, this issue will occur.

     

    0
  • Jordan Western

    hi vadivel.sekar81

    Strangely in any of these cases I am not facing any issues.

    Are you able to send a project to info@specflow.org so I can take a look?

     

    0
  • vadivel.sekar81

    Hi Jordan,

    Thanks for the update,

    I have created a new project and if SpecFlow is installed dependencies mentioned were not installed (such as BoDi and Cucumber.Message) but in old project these were installed individually and the error persist.

    Screenshot:

    0

Please sign in to leave a comment.

Powered by Zendesk